2008 Stern Batman Dark Knight Repairs

Stern Batman up and running again!

Stern Batman up and running again!

This one is out of the personal collection. Recently got it in a trade deal for my Williams Congo. Part of the trade deal was that there was a fuse blowing on the I/O Power Driver board, which was fine with me.

F110 was the fuse in question that was blowing, which is the 16VAC fuse. This voltage is rectified by BR2 to the +20VDC which powers the low power solenoids and flash lamps in the game.

To help in diagnosis, it’s a good idea to isolate whether the issue is a board issue or a potential short from the playfield. To do this, I noticed that the low power and flash lamp connectors were J6 and J7. So, I removed these connectors with the game off and then turned the game on. To help conserve fuses for this test, I used by 5amp circuit breaker fuse (a mini 5 amp fast blow circuit breaker that I soldered a fuse on the end of.)

Sure enough, no fuse blowing. So, this told me that the issue was coming from the playfield. I then plugged in J6, no fuse blow. Then, J7 and viola there goes our fuse. So, something in line with J7 was causing the fuse to pop.

With the game on and my circuit breaker fuse reset, I barely plugged in J7 and got a spark from roughly pin 6 or 7. Checked the schematic to see that these were a series of Joker flash lamps or another issue.

A flash lamp mod to the backbox had been added on this game which used jumpers off of one of the Joker flash lamps. The leads had been bent up and were touching causing the dead short to go back to the board and blow fuse F10. I realigned these jumpers and reset my circuit breaker fuse and turned the game back on — no blown fuse! However, we had all flashers in that line “locked on”, meaning the driver transistor on the board was likely blown, which was not surprising considering the dead short.

I checked schematics and found the driver transistor for those flash lamps was Q22, a TIP122 transistor. I pulled the board, confirmed the blown TIP122, and replaced with a sturdier TIP102. Board plugged back and in and boom, everything working and no blown fuse.

The only other issue I found on the game was a dead right flipper, which easily ended up just being a missing 3amp flipper fuse. Quick shop, new super bands, new balls, some replaced LEDs and adjustments and its back up to speed and playing nicely.

Advertisements

About Matthew Mandarano

Matthew is a cinematographer and video specialist by day and pinball fanatic at night. Somewhere in between he also finds time to play the guitar, collect vinyl records and watch a good deal of movies and TV shows.
This entry was posted in Repairs and tagged , , , , , , , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s